Interruptions on access to app.tricent.com
Incident Report for Tricent Operational Status
Resolved
Normal operations have now been restored, but we continue to monitor the affected systems closely.

Once again we would like to apologize for any inconvenience caused by this incident.

If you have questions concerning the above, you are more than welcome to contact us via support@tricent.com or +45 7071 3131

Best regards,
Tricent Support
Posted May 24, 2023 - 09:47 CEST
Investigating
We are currently experiencing interruptions on access to app.tricent.com.

We are working to identify the root of the problem and will return with new status no later than 10:30 AM (CEST).

We apologize for any inconvenience caused.

Best regards,
Tricent Support
Posted May 24, 2023 - 09:27 CEST
This incident affected: Tricent for Google Workspace (Tricent for Google Workspace - web frontend).