Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 12, 2023 - 00:00 CET
Scheduled
As part of our work to further improve our systems, we hereby schedule a maintenance window. The window will allow us to replace the core database backend, which handles the bulk of the Tricent for Microsoft 365 service.
We apologize for any inconvenience caused by the work.
When? From Thursday, 12 January at 00:00 until Sunday, 5 February at 24:00.
What does this mean to you? During the maintenance window, you will not have access to Tricent for Microsoft 365, and no cleanup of shares will be carried out.
Questions? If you have any questions regarding the above, you are more than welcome to contact Tricent Support at support@tricent.com.
Posted Jan 10, 2023 - 14:27 CET
This scheduled maintenance affected: Tricent for Microsoft 365 (Tricent for Microsoft 365 - data engine, Tricent for Microsoft 365 - cloud infrastructure, Tricent for Microsoft 365 - web frontend, Tricent for Microsoft 365 - email service).