We are currently experiencing delays in processing email send-outs.
Incident Report for Tricent Operational Status
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 15:16 CEST
Update
Normal operations have now been restored, but we continue to monitor the affected systems closely.

Once again we would like to apologize for any inconveniences caused by this incident.

If you have questions concerning the above, you are more than welcome to contact us via support@tricent.com or +45 7071 3131

Best regards,
Tricent Support
Posted Jun 10, 2022 - 15:16 CEST
Update
We are still pursuing the root of the problem and will come back with a new status no later than 15.00 today.

We apologize for any inconvenience caused.

Best regards,
Tricent Support
Posted Jun 10, 2022 - 12:11 CEST
Investigating
We are currently experiencing delays in processing email send-outs.

We are working to identify the root cause of the problem and will get back with a status no later than 12:00

We apologize for any inconvenience caused.

Best regards,
Tricent Support
Posted Jun 10, 2022 - 09:55 CEST
This incident affected: Tricent for Google Workspace (Tricent for Google Workspace - email service).