Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 06, 2023 - 20:00 CEST
Scheduled
As part of our work to maintain and further improve our systems, we hereby schedule a maintenance window. This will allow us to work on our main database in order to enhance our reporting capabilities.
We apologize for any inconvenience caused by the work.
When? From Tuesday 6 June at 20:00 and the following 15 minutes - until 20:15.
What does this mean to you? During the maintenance window, you will experience interruptions in access to app.tricent.com.
Once the maintenance window has been completed, there is no need for action on your end – the solution will return to normal operation.
Questions? If you have any questions regarding the above, you are more than welcome to contact Tricent Support.
Posted May 23, 2023 - 14:44 CEST
This scheduled maintenance affected: Tricent for Google Workspace (Tricent for Google Workspace - web frontend).